MantisBT - DriverPacks BASE
View Issue Details
0000040DriverPacks BASEGUIpublic2006-05-28 10:262006-05-28 10:59
6.05 CP 
not applicable
not applicable
not applicable
0000040: When Finishing Method ="custom" in settings file, this setting isn't imported
Example of how to get the crash: In my DPs_BASE.ini file I have

finishMethod = "custom"

Now run the DPs_BASE.exe, go to Overview and it will report the finish method as GUIRunOnce. Now go change the finish method to RunOnceEx, then go to Overview. The DPs_BASE.exe will crash stating a variable was not declared.

There seems to be two issues. 1.) When executing the DPs_BASE.exe, it does not properly read the finish method of "custom". 2.) When the finish method is changed, then going to Overview, it crashes.

I am attaching a screenshot of the error message.
No tags attached.
related to 0000028resolved BashratTheSneaky when RunOnceEx as Finishing Method, but no RunOnceEx Settings set: AutoIt Error 
png BASE-Error.png (14,655) 2006-05-28 10:26
Issue History
2006-05-28 10:26RogueSpearNew Issue
2006-05-28 10:26RogueSpearFile Added: BASE-Error.png
2006-05-28 10:26RogueSpearDriverPacks => not applicable
2006-05-28 10:26RogueSpearDriverPacks Method => not applicable
2006-05-28 10:26RogueSpearFinishing Method => custom
2006-05-28 10:26RogueSpearInstallation Platform => not applicable
2006-05-28 10:45BashratTheSneakyRelationship addedrelated to 0000028
2006-05-28 10:45BashratTheSneakyNote Added: 0000136
2006-05-28 10:50RogueSpearNote Added: 0000137
2006-05-28 10:53BashratTheSneakyStatusnew => assigned
2006-05-28 10:53BashratTheSneakyAssigned To => BashratTheSneaky
2006-05-28 10:53BashratTheSneakyStatusassigned => resolved
2006-05-28 10:53BashratTheSneakyFixed in Version => 6.05
2006-05-28 10:53BashratTheSneakyResolutionopen => fixed
2006-05-28 10:53BashratTheSneakyNote Added: 0000138
2006-05-28 10:59BashratTheSneakyProjectionnone => tweak
2006-05-28 10:59BashratTheSneakyETAnone => < 1 day
2006-05-28 10:59BashratTheSneakySummaryChanging the "Finishing Method" can produce a crash => When Finishing Method ="custom" in settings file, this setting isn't imported

2006-05-28 10:45   
1) was reproduced

2) already solved, see bug 0000028: [^]
2006-05-28 10:50   
I did not connect these two issues to each other. I'm sorry for the duplicate posting.
2006-05-28 10:53   
No problem :) It doesn't look the same at first sight.

Problem solved by the way.